
MCPro/FEP tutorial
Test Case #1 TPP/AChE



Download and Prepare a 
Protein Structure for Docking



Download 3D structure of Acetylcholinesterase (pdb id: 4m0e) from 
www.rcsb.org

as pdb format (4m0e.pdb)

All proteins are categorized by a 4 digit alphanumeric code, known as the pdb ID
You can use this code to find your protein if you know it  (you can also searches by name, 
ligand, author, etc.)

http://www.rcsb.org


Open 4m0e.pdb in chimera:
→Select → Chain → B                            
→Actions→ Atoms/Bond→Delete

#The protein is a dimer you will only need one chain so 
you are deleting the other
→Select → Residue→all nonstandard
→Actions→ Atoms/Bond→Delete
#This will delete any ligands, ions, etc that are bound to 
the protein
→Tools→Structure Editing→DockPrep
#This brings up the menu to prepare the structure for 
docking: Deletes any solvent molecules, adds H’s, 
charge, and fixes incomplete side chains

Uncheck Mol2 file, we will save the structure as a pdb
to use in further prep for docking

Prepare your protein for Docking using the Dockprep function of
Chimera to add hydrogens, remove solvent ions, excess ligands,
cofactors, or subunits, and repair incomplete side chains



Change the selection from “Residue-
name-based” (default) to “Unspecified 
(determined by method)” 

#Residue-name-based will simply assign a 
default protonation state based on the 
name of the residue

Ex) HIP = doubly protonated histidine

We want to instead calculate the 
protonation states 

Prepare your protein for Docking using the Dockprep function of
Chimera to add hydrogens, remove solvent ions, excess ligands,
cofactors, or subunits, and repair incomplete side chains



Select the AM1-BCC charges

#These charges will not 
actually be used so you could 
really use either but the AM1-
BCC charges should be more 
consistent with our forcefield. 

Prepare your protein for Docking using the Dockprep function of
Chimera to add hydrogens, remove solvent ions, excess ligands,
cofactors, or subunits, and repair incomplete side chains



File -> Save PDB
4m0eAprep.pdb

Pick a name that indicates 
the changes/prep you’ve 
done

Save�your�prepped�protein�as�a�pdb



Prepare�your�chosen�Ligand�(TPP)�for�
Docking

l You will need a PDB for docking there are several 
ways to do this:
l 1) Draw your ligand in Marvin 
l

l 2) Draw your ligand in LigParGen Server and 
download as a pdb



Preparing Ligand with Marvin

l Open MarvinSketch and draw your structure:
l Triphenyl phosphate with a chlorine substituted in the para position
l

l

l Use clean in 3D to get a loosely optimized structure:
l Structure → Clean 3D → Clean in 3D
l (it will look crazy because its 3 dimensions shown in 2, don't worry)
l

l

l Save as a pdb:
l File → Save as → “Ligand.pdb”
l

l

l



Use autodock tools to prepare input file of 
ligand for docking with autodock Vina

l Type “adt” in the command line to open autodock tools
l Ligand → Input → Open → TPP.pdb
l Ligand → Choose torsions (are they correct?) → Done
l Ligand → Output → TPP.pdb → save TPP.pdbqt
l Close autodock tools
l



Use autodock tools to prepare input files from your 
prepped protein for autodock Vina

l Type “adt” in cmd line
l Open the pdb of your protein that you prepped in Chimera:

- File → Read molecule → 4m0eAprep.pdb
- Edit → Delete water (should already be done)
- Edit → Hydrogens → Merge non-polar
- Grid → Macromolecule → choose → 4m0eAprep.pdb 
- (creates 4m0eAprep.pdbqt)



l Select Key Residues that will be allowed to rotate during 
docking:
- Select → select from string:

l MET85  TRP86  TYR124  TYR133  SER203  GLU202  PHE297  TRP236  
- PHE295  TYR337  TRP286  HIS447  PHE338  GLU450  TYR449  ILE451

Use autodock tools to prepare input files from 
your prepped protein for autodock Vina



l Flexible residues → Input → Choose macromolecule → 4m0eAprep.pdbqt
l Flexible residues → Choose torsions
l Flexible residues → Output → Save Flexible PDBTQ (4m0eAprep_flex.pdbqt)
l Flexible residues → Output → Save Rigid PDBTQ (4m0eAprep_rigid.pdbqt)

Use autodock tools to prepare input files from 
your prepped protein for autodock Vina



Assigning Dimensions for your Docking Search Space

l Use the grid box feature visualize what dimensions will encompasses the 
flexible residues you have selected and be appropriate to search for 
potential binding poses

l Grid → grid box
- Change Spacing to 1.000 (for Å)
- Adjust coordinates and size so that box encompasses flexible residues (aka binding 

pocket)
- Record dimensions and coordinates!! 

l These will define where the docking algorithm should look for potential binding poses
l You will need to put them into your configuration file 

- Close ADT



Setting up your config file and executing a docking 
simulation with Vina

config_4m0eA.txt

Create a configuration file in your favorite text editor (as 
shown on the left)

Assign: -flex file
-grid box coordinates
-grid box size
-exhaustiveness

Transfer files into Bound folder:
-4m0eAprep_flex.pdbqt
- 4m0eAprep_rigid.pdbqt
-config_4m0eA.txt
-TPP.pdbqt

Run your Docking Simulation in Vina!!
vina --receptor 4m0eAprep_rigid.pdbqt --ligand TPP.pdbqt --config config_4m0eA.txt –log TPP.log

(or ./xRUNVINA 1qkm_Rigid.pdbqt conf.txt)
If “unknown option flex” error run 

vina --receptor 4m0eAprep_rigid.pdbqt –flex 4m0eAprep_flex.pdbqt
--ligand TPP.pdbqt --config config_4m0eA.txt –log TPP.log

Coordinates for each pose and flexible residues will be in TPP_out.pdbqt
Summary tables of the results are found in TPP.log

For a summary of all the flags in vina type “vina --help”



xFLEXRESPREP_v3 Check
Edit xFLEXRESPREP_v3 to make sure your UNK digit (either 0 
or 1) matches your TPP_out.pdbqt file. If they do not match your 
TPP will not show up in your poses. 

xFLEXRESPREP_v3 TPP_out.pdbqt



l Use the xFLEXRESPREP script to add the coordinates of the ligand and flexible residues to the Rigid 
pdb for each pose:

./xFLEXRESPREP_v3 TPP_out.pdbqt 4m0eAprep_rigid.pdbqt

Use Chimera to protonate the structure (for docking we merged all non-polar hydrogens)
Open resulting pdb's in Chimera:
-Tools → Structure Editing → AddH
Check unspecified (determined by method)

Save structures as .pdb files (you will only need the top pose for this tutorial)

Combine the docking poses obtained from TPP4Cl_out.pdbqt with the Rigid 
receptor (4m0eAprep_rigid.pdbqt) to obtain a structure file for each pose bound to 

the receptor



Make zmatrix for your FEP that includes parameters for both the 
final  and initial structures of your ligand 

initial final



Step 1: Isolate your ligand in correct pose to obtain a pdb for your 
initial state

Save the structure of the ligand (in the correct pose) without the receptor as a pdb:
Open pdb file (with ligand, flex residues, and hydrogens) in Chimera
Select → Residue → UNK
Select → Invert (selected models)
Actions → Atoms/Bonds → delete
File → Save PDB…   save as “TPP4Clpose1.pdb” 

Select ligand 
“UNK”

Invert selection so that 
everything but the ligand 

is selected

Delete selected 
atoms leaving 
only the ligand



Step 1: Use the ligand of your initial state in the correct pose to 
obtain a pdb for your final state

Use pymol to change the Cl atom to an H atom and save as the pdb for your final state:
Click on “Builder” in the top right corner to pull up the builder menu

Then select the “Delete” button under the “Atoms” menu
Note: make sure your rings are cyclized or it will not correctly protonate when the Cl is deleted

Click on the Chlorine atom to delete (replace with H)

Save your final state (TPP) as a pdb:
File → Save molecule → Select “TPP4Clpose1” as object 
you'd like to save → Save as “TPP4Hpose1.pdb”

Close pymol



Generating zmatrix coordinates and parameters for the pdb files 
of your intial and final ligand structures 

Download as an 
MCPRO/BOSS compatible 

zmatrix

There are 2 ways (at least) to do this:

1) Ligpargen server: http://zarbi.chem.yale.edu/ligpargen/index.html

Upload the pdb file of your initial state
Click “submit molecule”
Download as a BOSS/MCPRO ZMAT (and rename 

“TPP4Clpose1.z)
Repeat for final state

Confirm that the structure 
of your ligand is correct You can rotate to see the 

entire geometry in the 
Jsmol window 

http://zarbi.chem.yale.edu/ligpargen/index.html


Generating zmatrix coordinates and parameters for the pdb files 
of your intial and final ligand structures 

There are 2 ways (at least) to do this:

2) xPDBMCP script (use this method if the server is down)

Execute the script by typing “./xPDBMCP TPP4Clpose1
Check that the structure is reasonable via the .plt file that is output
Repeat for both states

Open the .z files in a text editor like vim and add an extra blank 
line at the end of the file 

*this is necessary for compatibility with the python script we will 
use to generate our FEP zmatrix

*it is written to take the zmatrices produced by ligpargen as inputs 
which are formatted to have an extra line at the end of the file



Generate a single FEP zmat with parameters from both initial and final zmatrices of your 
ligand

The python script “make_single_topology will produce the FEP zmat with both parameters

Format: python make_single_topology -i initial.z -f final.z -n new.z

Ex) python make_single_topology -i TPP4Cl.z -f TPP.z -n TPP4CltoH.z

Nonbond parameters for final zmat

Atom type codes:
800 = initial zmat
9500 = final zmat

FEP ZMAT
TPP4CltoH.z



Setup the FEP calculation for unbound ligand

Create a folder: TPP4CltoH.fep
Copy the following items into TPP4CltoH.fep:

l TPP4CltoH.z
l fepcmd
l feppar
l feppar0

Assign TPP4CltoH.z as your zmatrix in 
fepcmd file:

setenv ZMATRIX   TPP4CltoH.z

Geometry Variations follow    (2I4,F12.6)
00280001 1.08

Variable Bonds follow         (I4)
4
5
6
7
8
9

10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
29

Remove atom to be mutated from variable 
bonds

Execute calculation in 
Separate folder:

csh fepcmd >& log &



clu -t 4m0eTPPClpose1.pdb -r TPP4Clpose1toH.z -n 4m0eTPP4Clpose1_cplx.pdb

Replaces ligand (TPP) in pdb specified by “-t” flag with that specified by “-r” flag creating a new 
pdb specified by the “-n” flag

**Be sure to overlay structures in Chimera to see if your ligand is not in a substantially 
different position

à If structures match ignore the “Unmatched record in replacement ligand file :
Atom    C    UNK 1.  -0.8.   1.   0” code 
For more options and info see “Users guide to clu” in MCPRO manual

CLU 
(complex ligand utility)



Chop

$home/username/mcpro2016/mcpro/miscexec/chop -u -i 4m0eTPP4Clpose1_cplx.pdb
chop> add center :UNK
chop> set cap origin :c01
chop> set cut origin ligand
chop> set cut size 15

213 Residues, Total Charge = -8 ##for tutorial okay if it doesn’t match (-4 for mine)
7ASP(-), 11GLU(-), 2LYS(+), 8ARG(+), 0HIP(+)
0ASH(0), 0GLH(0), 0LYN(0), 0ARN(0), 6HIS(0), 0HID(0), 0HIE(0)

chop> fix chains
232 Residues, Total Charge = -9
9ASP(-), 12GLU(-), 2LYS(+), 10ARG(+), 0HIP(+)
0ASH(0), 0GLH(0), 0LYN(0), 0ARN(0), 6HIS(0), 0HID(0), 0HIE(0)
227 Residues, Total Charge = -9
9ASP(-), 12GLU(-), 2LYS(+), 10ARG(+), 0HIP(+)
0ASH(0), 0GLH(0), 0LYN(0), 0ARN(0), 6HIS(0), 0HID(0), 0HIE(0)
Warning: not all chains could be fixed automagically, please do it manually

chain #7 [ARG(247A)] is only 1 residues long, chain #14 [TRP(480A)] 
is only 1 residues long, chain #15 [LEU(524A)-ARG(525A)] is only 2 residues long

Execute chop on in text mode on pdb

adds center of ligand (:C01@C01)

completes chains

makes this center the origin of water cap
define cut from all atoms in ligand

cuts residues within 15Å

http://C01


Chop

Warning: not all chains could be fixed automagically, please do it manually
chain #7 [ARG(247A)] is only 1 residues long, chain #14 [TRP(480A)] 

is only 1 residues long, chain #15 [LEU(524A)-ARG(525A)] is only 2 residues long
chop> delete cut :247a

226 Residues, Total Charge = -10
9ASP(-), 12GLU(-), 2LYS(+), 9ARG(+), 0HIP(+)
0ASH(0), 0GLH(0), 0LYN(0), 0ARN(0), 6HIS(0), 0HID(0), 0HIE(0)

chop> delete cut :524a
225 Residues, Total Charge = -10
9ASP(-), 12GLU(-), 2LYS(+), 9ARG(+), 0HIP(+)
0ASH(0), 0GLH(0), 0LYN(0), 0ARN(0), 6HIS(0), 0HID(0), 0HIE(0)

chop> delete cut :525a
224 Residues, Total Charge = -11
9ASP(-), 12GLU(-), 2LYS(+), 8ARG(+), 0HIP(+)
0ASH(0), 0GLH(0), 0LYN(0), 0ARN(0), 6HIS(0), 0HID(0), 0HIE(0)

chop> delete cut :480a
223 Residues, Total Charge = -11
9ASP(-), 12GLU(-), 2LYS(+), 8ARG(+), 0HIP(+)
0ASH(0), 0GLH(0), 0LYN(0), 0ARN(0), 6HIS(0), 0HID(0), 0HIE(0)

deletes residue 247A



Chop
chop> fix chains
chop> cap all

223 Residues, Total Charge = -12
8ASP(-), 12GLU(-), 2LYS(+), 6ARG(+), 0HIP(+)
0ASH(0), 0GLH(0), 0LYN(0), 0ARN(0), 5HIS(0), 0HID(0), 

0HIE(0)
chop> set variable origin ligand
chop> set variable size 10
chop> fix charge +0

Target charge = +0, Current charge = -12
isOK = 1
223 Residues, Total Charge = +0

chop> write pdb 4m0eTPP4Clpose1.chop.pdb
chop> write pepz all 4m0eTPP4Clpose1.chop.all.in
chop> write pepz variable 4m0eTPP4Clpose1.chop.var.in
chop> write translation 4m0eTPP4Clpose1.chop.tt 
chop> exit

completes chains
adds Ace and Ame neutral caps 

defines variables from all atoms in ligand
makes residues beyond 10Å fixed
neutralizes enough residues to reach the 
target charge given. Target charge should be 
assigned so that the charge of the ligand + 
protein = 0

writes the new pdb file
writes pepz input for minimization
writes pepz input for simulation
Writes translation table file
stops chop



./xRESINTAN_v5

***AA residue integrity analyzer***
***********************************
**USE ON CHOP GENERATED PDBS ONLY**

Input pdb file to examine: 
4m0eTPP4Clpose1.chop.pdb

Use script to check for missing atoms:

If you do not receive an output message, all residues are intact



cp 4m0eTPP4Clpose1.chop.all.in 4m0eTPP4Clpose1.all.in
cp 4m0eTPP4Clpose1.chop.var.in 4m0eTPP4Clpose1.var.in

$ title [ADD YOUR TITLE HERE]
$ read database  $MCPROdir/AA/oplsaa.db
$ read dihedrals $MCPROdir/AA/dihedrals.aa
$ read parameter $MCPROdir/AA/oplsaa.par
$ read boss [WRITE NAME OF YOUR solute z-matrix FILE]
$ set parameter type ALL *
$ set override domain 1-223
$ sequence
ACE GLN SER VAL CYS TYR GLN TYR VAL ASP THR LEU TYR PRO GLY
PHE GLU GLY THR GLU MET TRP ASN PRO ASN ARG GLH LEU SER GLH
ASH CYS LEU TYR LEU ASN VAL AME TER ACE TRP ILE TYR GLY GLY
GLY PHE TYR SER GLY ALA SER SER LEU ASP VAL TYR ASH GLY ARG
PHE AME TER ACE VAL SER MET ASN TYR ARG VAL GLY ALA PHE GLY
AME TER ACE VAL GLY LEU LEU ASH AME TER ACE GLY GLU SER ALA
GLY ALA ALA SER VAL GLY MET AME TER ACE LEU GLN SER GLY ALA
PRO ASN GLY PRO TRP ALA THR AME TER ACE GLN VAL LEU VAL ASN
HIS GLH TRP HIS VAL LEU PRO GLN GLH SER VAL PHE ARG PHE SER
PHE VAL PRO AME TER ACE GLY VAL VAL LYS ASH GLU GLY SER TYR
PHE LEU VAL TYR GLY ALA PRO GLY PHE SER LYS AME TER ACE VAL
ARG VAL GLY VAL AME TER ACE GLH ALA LEU SER ASH VAL VAL GLY
ASH HIS ASN VAL VAL CYS PRO VAL ALA GLN AME TER ACE VAL PHE
GLH HIS ARG ALA SER THR LEU SER TRP PRO LEU TRP MET GLY VAL
PRO HIS GLY TYR GLU ILE GLU PHE ILE PHE GLY ILE AME TER ACE
ASN AME TER ACE ALA PHE TRP AME TER UNK TER CAP
$ center
$ set variable all 1-222
$ read pdb 4m0eTPP4Cl.chop.pdb
$ write pdb [NAME OF pdb file TO BE WRITTEN]
$ write zmatrix [NAME OF THE z-matrix TO BE WRITTEN]

AchE/TPP4CltoHpose1

TPP4CltoH.z

AChETPP4CltoHpose1all.z
(AChETPP4CltoHpose1var.z)

Delete this line

4m0eTPP4Clpose1.all.in:

Make the same edits to AChETPP4CltoHpose1.var.in but change name of zmat to be written(all→var)



./xPEPZ filename.all à example: ./xPEPZ 4m0eTPP4CltoHpose1.all    
if ( ! ( 1 ) ) then
if ( ! ( -e 4m0eTPP4Cl.all.in ) ) then
/home/klm2/mcpro2016/mcpro/miscexec/pez.old -i 4m0eTPP4Cl.all.in -o 4m0eTPP4Cl.all.out

WARNING: residue 214(ACE) cannot be moved in a conrotatory fashion but it contains backbone variables; MC moves 
will be used

WARNING: residue 215(ASN) cannot be moved in a conrotatory fashion but it contains backbone variables; MC moves 
will be used

WARNING: residue 216(AME) cannot be moved in a conrotatory fashion but it contains backbone variables; MC moves 
will be used

WARNING: residue 222(UNK) cannot be moved in a conrotatory fashion but it contains backbone variables; MC moves 
will be used

WARNING: residue 223(CAP) cannot be moved in a conrotatory fashion but it contains backbone variables; MC moves 
will be used
exit

./xPEPZ filename.var à example: ./xPEPZ 4m0eTPP4CltoHpose1.var   

PEPZ writes a zmatrix with all degrees of freedom variable based on the instructions in 
4m0eTPP4Clpose1.all.in

PEPZ writes a zmatrix with only the degrees of freedom selected in chop variable based on the 
instructions in 4m0eTPP4Clpose1.var.in

PEPZ



Geometry Variations follow    (2I4,F12.6)
3140   1    1.080000

Delete all Geometry variations from AChETPP4CltoHpose1all.z:

These lines  specify the geometry changes for the FEP (Cl→H)

They will cause problems in our optimization if left in

We need to optimize the zmatrix of the ligand/protein cplx we just created before FEP 
calculations

Relax “Chopped” Complex



Move OPTCG9cmd, OPLSCH9par to folder from test job cdk2 
(will get error if not copied)

./xOPTCG9 AChETPP4CltoHpose1all

Relax protein/ligand complex with 30 steps of conjugate gradient minimization

Output:   AChETPP4CltoHpose1all.out (output file)
AChETPP4CltoHpose1all.sum (optimized z-matrix)
AChETPP4CltoHpose1all.pdb (pdb formatted structure) 

l Use pdb to visually check 
structure 

l Find a centrally located 
residue/atom of the protein 
and record it's atom id (ex. 
Ser48/OG)

Replace the coordinates of the 
AChETPP4CltoHpose1var.z
with those from the sum file 
and save as 
AChETPP4CltoHpose1cap.z



Open AChETPP4CltoHpose1cap.z in a text editor
l Delete all “TERZ” except the last 2
l Find the residue/atomid you recorded earlier:
723 OG   154  154  722    1.417039 719  114.213488 717   77.001169 SER   48

l Record atom # (723)
l Record the atom number for a central atom of the ligand (ex “P” 3116)
l Remove the atoms you are mutating from from the variable bonds list:

Geometry Variations follow    (2I4,F12.6)
3140   1    1.080000

Variable Bonds follow         (I4)
3116
3117
3118
3119
3120
3121
3122
3123
3124
3125
3126
3127
3128
3129
3130
3131
3132
3133
3134
3135
3136
3137
3138
3139
3141

Delete 3140



JAWS (Just Add Water Molecules)
Use JAWS to generate solvent coordinate input file (this gives you buried waters that other 
methods may not include)
l

Create a folder: AChETPP4CltoHpose1cap
Copy the following items into AChETPP4CltoHpose1cap:

l AChETPP4CltoHpose1cap.z
l Jaws_cmd
l phase0.par
l phase1.par
l phase2.par

Edit par files phase0.par, phase1.par, phase2.par as indicated in red:

NCENT1, NCENT2  (THE ATOMS USED TO DEFINE THE CENTER OF THE SOLUTE(S))
07233116 INTEGERS IN I4 UNLESS NOTED.

NROTA1, NROTA2  (THE ATOMS SOLUTES 1 & 2 ARE ROTATED ABOUT - NOTE:
07233116 ROTATIONS DO NOT CHANGE THEIR RELATIVE POSITIONS)

GSTEP, GSIZE, NGSKIP, NGRESTR, NTARGET, GRIDDIFF, NGRIDATOMS (-1 means solute 2)
1.0      3.0 0  0  0  0  -1

Atom #'s recorded earlier (Ser48/OG & P atom of ligand)



JAWS
Give the command file (Jaws_cmd) the name of your zmat:

# Name of the Z-matrix file:

setenv ZMATRIX  AChETPP4CltoHpose1cap.z

GR-phase0.001.pdb
Gridpoints where waters were observed

Run JAWS:csh Jaws_cmd >& Jaws.log &

See “ReadMe file in 
$MCPROdir/testjobs/JAWS/neuraminidase for more details 
about input/output

# of predicted waters 
(record this number)



FEP setup (bound) 
Create a folder: AChETPP4CltoHcap.fep
Copy the following items into AChETPP4CltoHcap.fep:

l AChETPP4CltoHcap.z
l JAWS-all.in
l FEP_q.cmd
l CAPpar
l SLVpar

Edit SLVpar & CAPpar as follows:

NMOL
435

NCENT1, NCENT2  (THE ATOMS USED TO DEFINE THE CENTER OF THE SOLUTE(S))
07233116                            INTEGERS IN I4 UNLESS NOTED.

NROTA1, NROTA2  (THE ATOMS SOLUTES 1 & 2 ARE ROTATED ABOUT - NOTE:
07233116           ROTATIONS DO NOT CHANGE THEIR RELATIVE POSITIONS)

Give the command file (FEP_q.cmd) the name of your zmat and make sure it is set to 11 windows with double-wide 
sampling:

# Name of the Z-matrix file:

setenv ZMATRIX  AChETPPCltoHpose1cap.z

set numwin = 28
@ dw = 1

# of water molecules from JAWS-all.in 

*Get edited version of 
FEP_q.cmd from me



FEP setup (bound)
Sign onto ColonialOne

Execute command file: csh FEP_q.cmd_JK >& FEP_q.log &

This will create a directories with all the necessary files for each window of the FEP 

Create submission script with xDO2ALL_v7:
xDO2ALL_v9 mc2q 0-20 fepcmd (fix paths)

Execute!
./ALL2Q (make ALL2Q and submit files executable)

Check Status of your calculation:
Type “squeue”

Use xDELG to get ΔΔG:   ./xDELG ERTPP3x2FtoHpose1cap

**(move outputs for each window to parent folder first “mv l*/ *.”)

You may delete *.in *.up *.sv and *.av files but be sure to keep *.sum *.out and *.pdb

Use Chimera, Pymol, or VMD to visualize the pdb files for each window to be sure the correct 
mutation has occured


